App-V 5.0 SP2 Hotfix Package 2

Back in Februrary, I reported that Hotfix Package 1 was out for App-V 5.0 SP2 which fixed an issue we saw with QuickBooks. A little over a week ago Microsoft released Hotfix Pakcage 2 for App-V 5.0 SP2 and has the following fixes:

Issue 1

Certain App-V 5.0 Service Pack 1 (SP1) packages do not work with the App-V 5.0 Service Pack 2 (SP2) clients.

This is an issue in AppV 5.0 SP2 that may appear to prevent some applications from starting. This includes packages that were sequenced on earlier versions of App-V 5.0. A valid App-V 5.0 package starts correctly and displays a GUI under App-V 5.0 SP1. Under App-V 5.0 SP2, the same package does not display a GUI, or it appears not to start.

Issue 2

A sharing violation occurs during profile synchronization when you use App-V 5.0.

When an App-V user on a Remote Desktop Services (RDS) server logs on after a period of inactivity, a sharing violation may occur when the profile is synchronized to the local cache. Therefore, some required files are not copied over, or they are renamed. In this situation, the profile becomes corrupted.

Issue 3

App-V client handlers leak in Remote Desktop Services (RDS).

When an RDS user logs off, App-V does not release some handles that it held specifically for this session, and therefore the resource cannot be reused. In this situation, the Session ID monotonically increases without reusing IDs from previously finished sessions.

Issue 4

A virtualized Excel Visual Basic for Applications (VBA) application fails if the path for the application contains Chinese or Japanese characters.

Issue 5

Certain applications don’t start after Hotfix Package 1 for APP-V 5.0 Service Pack 2 is applied.

Selected registry key values were removed after the deployment of Hotfix 1 for APP-V 5.0 Service Pack 2. This prevents some applications from starting. By reverting Hotfix Package 1 for APP-V 5.0 SP2, you restore these registry values to their default state. However, any existing customizations will be lost and will have to be redone.

You can request the download from Microsoft here.

App-V 5 sequencer reboot error

Have you ever rebooted your App-V 5 sequencer and expect to continue sequencing, but was greeted with the following error?

App-V5_FailResume

Well, I certainly have and I had a feeling it had to do with joining the VM to the domain. Searching the web doesn’t bring up a lot of information on this specific error and the event log isn’t helpful either. What I did find was that¬†Nicke has great a article about issues one may encounter when rebooting an App-V 5 sequencer.

Everything on the VM checked out until I got to the Scratch directory. I setup a test sequence and performed a reboot, but before I logged back into the machine I browsed to the Scratch directory via UNC and noticed it was empty. Well, if the Scratch directory is empty, how can you expect the sequencer to resume after a reboot? I made sure the directory was accessible and was being written to during a sequence. After some digging, I noticed the entire temp directory was cleared out upon reboot. This was confusing to me because there was no GPO applied to delete temp folders, redirect folders or set mandatory profiles. So I went ahead rolled my VM back to clean and set the following GPO:

GPO-TempFolder


 

Now I can reboot during the sequence and resume sequencing without any issues!